300 units and a 5* generic awakening gem missing from my account [edited by Moderator]

Theaidsman816Theaidsman816 Posts: 2
edited August 14 in Suggestions and Requests
Recently I was upgrading my 5* Mephisto and I noticed the "Use Items" button was greyed out. I was instantly confused and checked my inventory. The reason I was confused was that the only item I could have used on him was the gem. Lo and behold when I checked my inventory and the gem was gone. A few days later I saw that my units had gone down from 915 to 615. Please upvote so admins can see this.
Post edited by Kabam Porthos on

Comments

  • phillgreenphillgreen Posts: 1,641 ★★★
    Where did you get the gem?
  • Not 100% sure. May have been some sort of miscellaneous reward crystal.
  • benshbbenshb Posts: 216 ★★
    then it wasn't a generic awakening gem. you can only get those from 100% act 5 or 100% labyrinth of legends. it was probably an other class gem. can you send a screenshot of your inventory?
  • UmbertoDelRioUmbertoDelRio Posts: 1,776 ★★★★


  • Hey Theaidsman816, I'm sorry to hear you're seemingly missing an Awakening Gem and Units.

    Unfortunately, we don't have direct access to in-game accounts here in the Forums and are unable to help with account-specific issues like this. Therefore, I recommend reaching out to our Support Team for assistance. You can contact them by clicking HERE.

    Alternatively, if you would prefer to contact our Support Team from within the game, simply click on the gear shaped icon, located in the top left corner of the Home screen. From there, tap the button which says “Support”, then tap the button that says “Need more help? Contact us”.
This discussion has been closed.