Anyone's "Unknown Enemy" buff not working?

It seems more often then not when I activate Unknown Enemy buff when facing the Golden Symbiote it doesn't work (i.e. no parry, no bleed). I've tried it solo as well as paired with True Strike, Fight Dirty, Frenzy, Momentum. Anyone else experiencing this?

Comments

  • SolswerdSolswerd Posts: 1,439 ★★★
    edited October 2018
    th3_joseph wrote: »
    It seems more often then not when I activate Unknown Enemy buff when facing the Golden Symbiote it doesn't work (i.e. no parry, no bleed). I've tried it solo as well as paired with True Strike, Fight Dirty, Frenzy, Momentum. Anyone else experiencing this?

    The buff's description says it only works on "non-symbiote defenders", the Golden Symbiote...is a symbiote
  • In the fight screen, below where you usually find the hashtag descriptions of what a character is, the Golden Symbiote is blank, meaning he's not characterized as a symbiode.
  • ChampioncriticChampioncritic Posts: 2,127 ★★★
    th3_joseph wrote: »
    In the fight screen, below where you usually find the hashtag descriptions of what a character is, the Golden Symbiote is blank, meaning he's not characterized as a symbiode.

    not really, it just means his tags cannot be seen. he's not "tagged" as a villain either but blade danger sense with ghost rider still works against him. Besides, its pretty obvious that a golden symbiote is a symbiote lol
  • It works, just not everytime, it has a chance of reducing AA which is NOT 100%.
  • Thanks rocky. Videos I've seen online it always works, wasn't sure if there was a glitch or just bad luck.
Sign In or Register to comment.