Options

Avenger Use Event, No Rewards Discussion [Merged Threads]

1234689

Comments

  • Options
    Still nothing and now sa rewards are over two hours behind
  • Options
    So if I leave my current alliance and join new one, will I still receive both avenger use and SA rewards? Or do I need to wait until rewards are given?
  • Options
    Noob2435Noob2435 Posts: 627 ★★★
    Maldroit2 wrote: »
    I seem to be the only person who got both the peak milestone and ranked rewards. Am I alone in this?

    I got both also.
  • Options
    Recently there was an alliance event called the avengers use and we totally finished it and got to the rank rewards but did not get any rewards after it ended.
  • Options
    I also noticed this. When will the rewards arrive.
  • Options
    SteveMSteveM Posts: 188
    Still waiting for them too
  • Options
    CallmelaFleurCallmelaFleur Posts: 231
    Never got mine.
  • Options
    thegrimmlingthegrimmling Posts: 167
    Still nothing
  • Options
    hydrogohardhydrogohard Posts: 222 ★★
    This is just ridiculous now... still no rewards
  • Options
    FhfjghhggggjfhfjgFhfjghhggggjfhfjg Posts: 4,492 ★★★★★
    Smh over 24 hours and still no avenger use rewards wtf is going on at kabam hq
  • Options
    SpiderCoolsSpiderCools Posts: 615 ★★★
    Some people in life say patience is important. Bet they didnt have to deal with this XD
  • Options
    thegrimmlingthegrimmling Posts: 167
    I can't remember the last time an event didn't take this ling to pay.

    Still waiting on mine
  • Options
    MrDMrD Posts: 30
    I did not receive the peak rewards and ranked rewards for the avenger use alliance event. We hit the top milestone and unlocked the ranked rewards. Can we get a fix on this pls??
  • Options
    MrDMrD Posts: 30
    Still nothing
  • Options
    The reward for SA arrived but where's the reward for the earlier Avenger Use one?
  • Options
    Iron_spider1Iron_spider1 Posts: 257
    You folks received the rewards for ranking in avengers use event? My alliance mates got it but not me...
  • Options
    This is getting ridiculous and stupid... My entire alliance hasn't received any of the rewards for avenger use yet and I sent a ticket in yesterday morning.
  • Options
    SpiderCoolsSpiderCools Posts: 615 ★★★
    edited September 2018
    Hey All,

    Thank you for your patience. We're still rolling these out, but they're taking longer than expected. We don't have much more that we can add at this time, but will let you know if you do find anything else out, or receive an expected timeline.

    I think people had patience. At this point i dont think they do anymore. Longer than expected is an understatement
  • Options
    DragonfeiDragonfei Posts: 260 ★★
    Might want to peek over at the 178 comment thread on this exact topic. :)
  • Options
    arksarks Posts: 25
    same thing happened to my alliance and they closed my case
  • Options
    BlackOracleBlackOracle Posts: 255 ★★★
    Just double the rewards every time this happens Kabam. Might help you with getting the bugs out of the game then.
  • Options
    Thafish20Thafish20 Posts: 22
    Been over a day for me and my alliance
  • Options
    Jawarrior2001Jawarrior2001 Posts: 303
    Dont worry at least we got Summoner Advancement rewards, not like that ended a day after this event, and that event ended over 36 hours ago but hey :disappointed:
  • Options
    SpiderCoolsSpiderCools Posts: 615 ★★★
    Hey nobody cares about these rewards. Thats why no one made a thread about it and why no one is complaining about these rewards....oh wait
Sign In or Register to comment.