The game team has resolved this issue. Keys will be distributed via in-game messages and the quest timer will be extended.
More information and timeline here.
*This includes currently unclaimable keys as well*
As previously announced, the team will be distributing an additional point toward milestones to anyone who completed the Absorbing Man fight in the first step of the Winter of Woe.
This point will be distributed at a later time as it requires the team to pull and analyze data.
The timeline has not been set, but work has started.

Guardian Profile Pic

Saw the Guardian Profile Pic in the store for only 80 units and was pretty excited for it. But every time I try to purchase it, the game crashes. What's going on? anyone else having this problem? Or am I the only one excited for a Guardian Profile Pic?


  • FallDogBombsMoonFallDogBombsMoon Posts: 12
    Having the same issue. Both before and after the emergency maintenance that just took place.
  • HowieN88HowieN88 Posts: 20
    Same here while purchasing new Wolverine profile pic.
  • DevoniusDevonius Posts: 32
    Same and I’ve sent in a ticket for them to rectify the problem...😏
  • 5olas5olas Posts: 12
    Is anybody else having this issue?
  • burnso81burnso81 Posts: 11
    It's doing it for me as well. Fix asap please.
  • MJWolverine21MJWolverine21 Posts: 18
    edited June 2020
    Same bub! Tried to buy it at least 12-15 times today. Same thing happening again and again.

    Where should I report it?
  • Sensei_MaatSensei_Maat Posts: 396 ★★★
    I was really excited when i saw the new Groot profile pic and think it looks awesome.
    However i was really disappointed when i tried to purchase it.
    i get disconnected whenever i try and purchase it.
    i tried twice and then tried a 3rd time and recorded it.
    2 of my alliance mates have also tried and had the same issue.

  • MJWolverine21MJWolverine21 Posts: 18
    Same while trying to buy Wolverine profile pic
  • Would anyone who is experiencing this be able to go through our troubleshooting steps for iOS or Android and let us know if you are still experiencing the issue and what operating system you are using?
  • After checking with a team, they pushed a fix that should've resolved this issue. Would you be able to restart your game and let us know if you are still experiencing the issue?
Sign In or Register to comment.