How Come Tablet with all Requirements Not Supported?

I have a Samsung Tablet 3 Lite and is wondering why the tablet is not supported? It meets requirements by being over 4.0 for the Android version, but being 4.2.2. I have quite a bit of memory available. So my question is that why this tablet is not supported?

Comments

Sign In or Register to comment.