**KNOWN ISSUE WITH SIDE QUEST KEYS**
The game team has resolved this issue. Keys will be distributed via in-game messages and the quest timer will be extended.
More information and timeline here.

APOC SP3 NOT WORKING in escape from Titan ep3

I now see a bunch of other posts talking about this stupid power shield node where defender takes 90% less damage except for specials.
Well last time I checked the power bars turning red and me launching a sp3 animation COUNTS AS A SPECIAL ATTACK.
Anyone else getting this issue? Maybe it’s an Apoc+node thing cuz a lot of these other posts specifically mention Apoc. Regardles, here I am yet again wasting units revives and health on a broken game like a complete jackass …🫤
«1

Comments

  • totheendoftotheendof Posts: 50
    I started another thread on this:

    I hit the boss Mantis with an SP3 from a Horseman 6* Domino and it had absolutely no effect. No reduction in health. I thought Specials were the main way to cause damage on this node and the bigger the special the more damage.

    A few other people said they had similar issues.
  • hmdemerahmdemera Posts: 78

    I started another thread on this:

    I hit the boss Mantis with an SP3 from a Horseman 6* Domino and it had absolutely no effect. No reduction in health. I thought Specials were the main way to cause damage on this node and the bigger the special the more damage.

    A few other people said they had similar issues.

    Where is this other thread? I want to post a video.
  • DemonzfyreDemonzfyre Posts: 20,724 ★★★★★
    Probably due to the fact that SP3's only count as 1 hit.
  • Mknight123Mknight123 Posts: 275 ★★★

    Probably due to the fact that SP3's only count as 1 hit.

    I had this same issue, for my first run in the new week of SQ, dropped an sp3 with apoc 0% damage, mantis was at 67% and stayed at 67% even after the sp3, then on my 2nd run through week 3 the sp3 hit counted against mantis and she died after the sp3 so definitely some sort of bug unless I'm missing a node that prevents the sp3 from doing any damage? This "bug" preventing my sp3 damage happened a few times during my threat lvl 5&4 runs.
  • SlurpZeDerpSlurpZeDerp Posts: 47
    Yeah I had it happen with dooms sp3 in his cycle
  • GroundedWisdomGroundedWisdom Posts: 36,089 ★★★★★

    Probably due to the fact that SP3's only count as 1 hit.

    Actually, I used a 7* Overseer in Level 3, and the L3 did 0 Damage, so there's something up.
  • GroundedWisdomGroundedWisdom Posts: 36,089 ★★★★★
    Tested again with Hulkling, no Damage with the Special 3.
  • DemonzfyreDemonzfyre Posts: 20,724 ★★★★★

    Probably due to the fact that SP3's only count as 1 hit.

    Really? Contribute something meaningful. No node supports your statement. One hit or 12 hit specials gain +200% attack. This fight is bugged.
    I'm going off the information the OP gave. I just fight with Apoc. I used a special 2, lots of damage. I didn't do an sp3 on that run yet.

    OP doesn't mention not doing ANY damage, just saying an SP3 doesn't work.

    We've been told over and over that SP3's only count as one hit. So if it's bugged, it might be that interaction that's causing it.
  • Mknight123Mknight123 Posts: 275 ★★★

    Probably due to the fact that SP3's only count as 1 hit.

    Really? Contribute something meaningful. No node supports your statement. One hit or 12 hit specials gain +200% attack. This fight is bugged.
    From what I've been reading from other threads i don't think it's mantis specifically, I think it's the power shield 2.0 node thats bugged.
  • ReignkingTWReignkingTW Posts: 2,379 ★★★★★
    Same w.cgr
  • [Deleted User][Deleted User] Posts: 0 ★★★★

    Probably due to the fact that SP3's only count as 1 hit.

    Really? Contribute something meaningful. No node supports your statement. One hit or 12 hit specials gain +200% attack. This fight is bugged.
    I'm going off the information the OP gave. I just fight with Apoc. I used a special 2, lots of damage. I didn't do an sp3 on that run yet.

    OP doesn't mention not doing ANY damage, just saying an SP3 doesn't work.

    We've been told over and over that SP3's only count as one hit. So if it's bugged, it might be that interaction that's causing it.
    Nah, the problem is caused by using a basic attack at the same time as you start an sp3. The node is bugged and counts the special as a basic attack.
  • JChanceH9JChanceH9 Posts: 764 ★★★
    I had the same happen with one of my champs.
  • xLunatiXxxLunatiXx Posts: 922 ★★★★

    Probably due to the fact that SP3's only count as 1 hit.

    Really? Contribute something meaningful. No node supports your statement. One hit or 12 hit specials gain +200% attack. This fight is bugged.
    I'm going off the information the OP gave. I just fight with Apoc. I used a special 2, lots of damage. I didn't do an sp3 on that run yet.

    OP doesn't mention not doing ANY damage, just saying an SP3 doesn't work.

    We've been told over and over that SP3's only count as one hit. So if it's bugged, it might be that interaction that's causing it.
    Nah, the problem is caused by using a basic attack at the same time as you start an sp3. The node is bugged and counts the special as a basic attack.
    Yes try to use your sp3 after backing off, not during a combo. It worked for me
  • AverageDesiAverageDesi Posts: 5,260 ★★★★★
    Try throwing special by not chaining from a combo.
  • willrun4adonutwillrun4adonut Posts: 2,849 ★★★★★
    For what it's worth, I can never get a sp3 to work if it's the first special I use. I found that using a sp1 or 2 and then sp3 allowed the sp3 to always give damage.
  • _nelynel_nelynel Posts: 33

    Probably due to the fact that SP3's only count as 1 hit.

    Really? Contribute something meaningful. No node supports your statement. One hit or 12 hit specials gain +200% attack. This fight is bugged.
    I'm going off the information the OP gave. I just fight with Apoc. I used a special 2, lots of damage. I didn't do an sp3 on that run yet.

    OP doesn't mention not doing ANY damage, just saying an SP3 doesn't work.

    We've been told over and over that SP3's only count as one hit. So if it's bugged, it might be that interaction that's causing it.
    Nah, the problem is caused by using a basic attack at the same time as you start an sp3. The node is bugged and counts the special as a basic attack.
    this makes absolutely no sense! the node prevents 90% damage so even if you managed to trigger it you should still be doing damage.
  • _nelynel_nelynel Posts: 33
    reposting this in other threads:
    another bug that we're going to complain about and then kabam will send out a message saying they'll look into it and 2 weeks later say they'll do nothing about it and we just sweep this bug under the rug and continue playing spending money and wait until the next bug and cry about it.
    endless abuse cycle
  • AverageDesiAverageDesi Posts: 5,260 ★★★★★
    _nelynel said:

    Probably due to the fact that SP3's only count as 1 hit.

    Really? Contribute something meaningful. No node supports your statement. One hit or 12 hit specials gain +200% attack. This fight is bugged.
    I'm going off the information the OP gave. I just fight with Apoc. I used a special 2, lots of damage. I didn't do an sp3 on that run yet.

    OP doesn't mention not doing ANY damage, just saying an SP3 doesn't work.

    We've been told over and over that SP3's only count as one hit. So if it's bugged, it might be that interaction that's causing it.
    Nah, the problem is caused by using a basic attack at the same time as you start an sp3. The node is bugged and counts the special as a basic attack.
    this makes absolutely no sense! the node prevents 90% damage so even if you managed to trigger it you should still be doing damage.
    My man, it's a bug. Not a node design
  • _nelynel_nelynel Posts: 33

    _nelynel said:

    Probably due to the fact that SP3's only count as 1 hit.

    Really? Contribute something meaningful. No node supports your statement. One hit or 12 hit specials gain +200% attack. This fight is bugged.
    I'm going off the information the OP gave. I just fight with Apoc. I used a special 2, lots of damage. I didn't do an sp3 on that run yet.

    OP doesn't mention not doing ANY damage, just saying an SP3 doesn't work.

    We've been told over and over that SP3's only count as one hit. So if it's bugged, it might be that interaction that's causing it.
    Nah, the problem is caused by using a basic attack at the same time as you start an sp3. The node is bugged and counts the special as a basic attack.
    this makes absolutely no sense! the node prevents 90% damage so even if you managed to trigger it you should still be doing damage.
    My man, it's a bug. Not a node design
    THAT'S LITERALLY MY POINT
  • [Deleted User][Deleted User] Posts: 0 ★★★★
    _nelynel said:

    _nelynel said:

    Probably due to the fact that SP3's only count as 1 hit.

    Really? Contribute something meaningful. No node supports your statement. One hit or 12 hit specials gain +200% attack. This fight is bugged.
    I'm going off the information the OP gave. I just fight with Apoc. I used a special 2, lots of damage. I didn't do an sp3 on that run yet.

    OP doesn't mention not doing ANY damage, just saying an SP3 doesn't work.

    We've been told over and over that SP3's only count as one hit. So if it's bugged, it might be that interaction that's causing it.
    Nah, the problem is caused by using a basic attack at the same time as you start an sp3. The node is bugged and counts the special as a basic attack.
    this makes absolutely no sense! the node prevents 90% damage so even if you managed to trigger it you should still be doing damage.
    My man, it's a bug. Not a node design
    THAT'S LITERALLY MY POINT
    That's just how it works, man. Kabam knows more about this issue than we do and it's their words, not mine. Go use your sp3 against her without doing a combo beforehand and see what happens.
  • GeneralMerceGeneralMerce Posts: 236 ★★
    this type of node has always been this way. sp3 never gets that damage boost sp1 and sp2 get.

    same kind of mechanic works for stuff like crit me if you dare + guaranteed crit buff. this doesnt work with SP3 for some reason even if you go into SP3 with a guaranteed crit
  • [Deleted User][Deleted User] Posts: 0 ★★★★

    this type of node has always been this way. sp3 never gets that damage boost sp1 and sp2 get.

    same kind of mechanic works for stuff like crit me if you dare + guaranteed crit buff. this doesnt work with SP3 for some reason even if you go into SP3 with a guaranteed crit

    It's not intended this time around
  • AverageDesiAverageDesi Posts: 5,260 ★★★★★

    this type of node has always been this way. sp3 never gets that damage boost sp1 and sp2 get.

    same kind of mechanic works for stuff like crit me if you dare + guaranteed crit buff. this doesnt work with SP3 for some reason even if you go into SP3 with a guaranteed crit

    Because sp3s cannot crit. They deal neither physical nor energy damage. They don't count for contact or non contact hits. It's how they are. Not a bug
  • AverageDesiAverageDesi Posts: 5,260 ★★★★★

    this type of node has always been this way. sp3 never gets that damage boost sp1 and sp2 get.

    same kind of mechanic works for stuff like crit me if you dare + guaranteed crit buff. this doesnt work with SP3 for some reason even if you go into SP3 with a guaranteed crit

    Sp3s do get the boost.
  • captain_rogerscaptain_rogers Posts: 2,488 ★★★★★
    Usually in power shield 2.0 nodes,sp3 sometimes won't work. I had the same problem with bishop sp3 in power shield 2.0 node in another quest
  • GeneralMerceGeneralMerce Posts: 236 ★★
    this is not that big of a deal

    "Regardless, here I am yet again wasting units revives and health on a broken game like a complete jackass"

    - its only 1 special that didn't land and you need to spend units and revives??? think of it as if you ended up landing a special into a block. Just build back up and release an sp2. Also, if you do die, you should have champs on your roster still very much alive for this fight. Plus its only 4 fights so if yo die, you can just restart if your roster gets wiped and try again.

    Please don't start asking for compensation, the comp calls are getting ridiculous.
  • _nelynel_nelynel Posts: 33

    _nelynel said:

    _nelynel said:

    Probably due to the fact that SP3's only count as 1 hit.

    Really? Contribute something meaningful. No node supports your statement. One hit or 12 hit specials gain +200% attack. This fight is bugged.
    I'm going off the information the OP gave. I just fight with Apoc. I used a special 2, lots of damage. I didn't do an sp3 on that run yet.

    OP doesn't mention not doing ANY damage, just saying an SP3 doesn't work.

    We've been told over and over that SP3's only count as one hit. So if it's bugged, it might be that interaction that's causing it.
    Nah, the problem is caused by using a basic attack at the same time as you start an sp3. The node is bugged and counts the special as a basic attack.
    this makes absolutely no sense! the node prevents 90% damage so even if you managed to trigger it you should still be doing damage.
    My man, it's a bug. Not a node design
    THAT'S LITERALLY MY POINT
    That's just how it works, man. Kabam knows more about this issue than we do and it's their words, not mine. Go use your sp3 against her without doing a combo beforehand and see what happens.
    that's not how it works man, go read the node. its not my job to do a workaround. if the node does not work properly kabam needs to fix it and be held accountable. players are always finding workarounds for bugs which is why NOTHING gets fixed unless it benefits us then it immediately gets fixed! I just want my revives it costed me; not looking for a compensation just something returned I shouldn't of had to use (no issues on threat 5 weeks 1&2 they were actually fun). apparently any items used during a timeframe in battlegrounds are being returned so do the same for this. its not hard....
  • [Deleted User][Deleted User] Posts: 0 ★★★★
    _nelynel said:

    _nelynel said:

    _nelynel said:

    Probably due to the fact that SP3's only count as 1 hit.

    Really? Contribute something meaningful. No node supports your statement. One hit or 12 hit specials gain +200% attack. This fight is bugged.
    I'm going off the information the OP gave. I just fight with Apoc. I used a special 2, lots of damage. I didn't do an sp3 on that run yet.

    OP doesn't mention not doing ANY damage, just saying an SP3 doesn't work.

    We've been told over and over that SP3's only count as one hit. So if it's bugged, it might be that interaction that's causing it.
    Nah, the problem is caused by using a basic attack at the same time as you start an sp3. The node is bugged and counts the special as a basic attack.
    this makes absolutely no sense! the node prevents 90% damage so even if you managed to trigger it you should still be doing damage.
    My man, it's a bug. Not a node design
    THAT'S LITERALLY MY POINT
    That's just how it works, man. Kabam knows more about this issue than we do and it's their words, not mine. Go use your sp3 against her without doing a combo beforehand and see what happens.
    that's not how it works man, go read the node. its not my job to do a workaround. if the node does not work properly kabam needs to fix it and be held accountable. players are always finding workarounds for bugs which is why NOTHING gets fixed unless it benefits us then it immediately gets fixed! I just want my revives it costed me; not looking for a compensation just something returned I shouldn't of had to use (no issues on threat 5 weeks 1&2 they were actually fun). apparently any items used during a timeframe in battlegrounds are being returned so do the same for this. its not hard....
    Okay, then just complain about it until Kabam dedicates all of their resources to making sure you can pull of a special 3 without having to wait a second first. If you want the revives it cost you, submit a support ticket and see what they have to say, the forums aren't a place to ask for personal compensation. Just don't freak out over such a small issue. You know how to work around it, so do it, or don't. They're working on it, and that's all they can do.
  • AverageDesiAverageDesi Posts: 5,260 ★★★★★
    _nelynel said:

    _nelynel said:

    _nelynel said:

    Probably due to the fact that SP3's only count as 1 hit.

    Really? Contribute something meaningful. No node supports your statement. One hit or 12 hit specials gain +200% attack. This fight is bugged.
    I'm going off the information the OP gave. I just fight with Apoc. I used a special 2, lots of damage. I didn't do an sp3 on that run yet.

    OP doesn't mention not doing ANY damage, just saying an SP3 doesn't work.

    We've been told over and over that SP3's only count as one hit. So if it's bugged, it might be that interaction that's causing it.
    Nah, the problem is caused by using a basic attack at the same time as you start an sp3. The node is bugged and counts the special as a basic attack.
    this makes absolutely no sense! the node prevents 90% damage so even if you managed to trigger it you should still be doing damage.
    My man, it's a bug. Not a node design
    THAT'S LITERALLY MY POINT
    That's just how it works, man. Kabam knows more about this issue than we do and it's their words, not mine. Go use your sp3 against her without doing a combo beforehand and see what happens.
    that's not how it works man, go read the node. its not my job to do a workaround. if the node does not work properly kabam needs to fix it and be held accountable. players are always finding workarounds for bugs which is why NOTHING gets fixed unless it benefits us then it immediately gets fixed! I just want my revives it costed me; not looking for a compensation just something returned I shouldn't of had to use (no issues on threat 5 weeks 1&2 they were actually fun). apparently any items used during a timeframe in battlegrounds are being returned so do the same for this. its not hard....
    Bruh it's literally just a frame difference.
Sign In or Register to comment.