Nebula sp2 bug [Under Investigation]

Doomed1144Doomed1144 Posts: 17
edited May 2017 in Bugs and Known Issues
Nebula special 2 no longer doubles shocks. They just disappear.
Post edited by Kabam Wolf on

Comments

  • Ccannon5Ccannon5 Posts: 25
    Yep just tried it
  • Also just tried it. Same result
  • sireriksonsirerikson Posts: 5
    I am also getting the same result, can we get a response on this.
  • Kabam WolfKabam Wolf Posts: 1,277 ★★★
    Hey there, @Doomed1144. I'm really sorry to hear that you're getting this issue with Nebula's Special 2 not stacking Shocks. We've sent this issue along to our team, and I'll get back to you in this thread once I hear back from them. Thanks for letting us know!
  • GargameshGargamesh Posts: 66
    Also going into block doesn't always start charging up her shocks...quite often I have to leave block stance to start blocking again in order to start charging blocks. Anyone else having this?
  • JustBeFineJustBeFine Posts: 31
    i don"t have any problem with nebula"s sp2
  • MsDominoMsDomino Posts: 72
    Gargamesh wrote: »
    Also going into block doesn't always start charging up her shocks...quite often I have to leave block stance to start blocking again in order to start charging blocks. Anyone else having this?
    Gargamesh wrote: »
    Also going into block doesn't always start charging up her shocks...quite often I have to leave block stance to start blocking again in order to start charging blocks. Anyone else having this?

    Yes...frequently.

    No issues with her sp2 though
  • Her special 1 is also broken. No power drain.
  • BigDWSUBigDWSU Posts: 206
    SP1 and 2 don't work. Bump
  • Doomed1144Doomed1144 Posts: 17
    I tested my sp2 in 5-2 and had no issues. Sp1 I don't seem to ever see a power drain, I do see power lock.
Sign In or Register to comment.