If a visual bug where’s my units?

Is anyone else having a bug where it’s not showing your correct units? It happened on both my main accounts. I had 5000+ and it showed 1900 something. Then when I went to main screen it switched back to normal. But on Chadpool I should have 3000 + that I was saving for the late comers tonight and it’s showing 2222 units now! I’ve exited out and came back in and it was the same. WTH is going on!


  • winterthurwinterthur Posts: 6,958 ★★★★★
    I had the same issue. Just restart the app and back to normal.
  • Dragfire1760Dragfire1760 Posts: 148
    Currently having the same issue, restarting the app hasn't worked either and I can claim the rewards before the units, I assume its a bug only regarding that milestone
  • Chadpool1Chadpool1 Posts: 341
    Glad sorta that I’m not the only one. At least I’m not crazy. When I saw them dip I about lost my mind
  • Hey there, sorry to hear about this. I would first try to go through our troubleshooting steps for iOS or Android, depending on what type of device you have. If that doesn’t solve the problem, I would get in contact with our Support Team. They can be reached from the game’s home screen by clicking the gear-shaped icon in the top-left corner of the screen and then scrolling down to the button labeled “Support”.
  • Chadpool1Chadpool1 Posts: 341
    I sent in a ticket. Not expecting any real help after the last few times I tried to go through them. I had one good experience with support I can remember. So I just used what was there. I’ve had this game glitch out so many things over the years I just took the 800 unit loss as a consequence of the game.
Sign In or Register to comment.