Iceman's Armor bug

2»

Comments

  • Deacon03Deacon03 Posts: 81
    Hey there @Deacon03, I'll pass this on to the rest of the team and have them look into it. Would you be able to tell me what node you were fighting on in AW when this happened?

    For the others who have experienced this, could you let me know what opponents you've experienced this with, as well as what mode you were in or node you were on? Thanks!

    @Kabam Zibiit it was Node 48 for tier 4 AW
  • @Kabam Zibiit
    I was fighting AW tier 2 node 22 against 6* deadpool. First sp3 was caped at 5% I gain ice armor again and second sp3 killed me.
  • kpkumardtskpkumardts Posts: 93
    Demonzfyre wrote: »
    The armor is only going to limit the first hit to 5%. After that, it goes on cool down. The entire sp3 isn't limited to the 5%.

    Entire SP3 is treated as one hit according to kabam
  • GarryDKGarryDK Posts: 17
    I had a bug with Iceman yesterday, sym spidey evaded whilst cold snap was active. this was in the daily trials.
  • SighsohardSighsohard Posts: 472 ★★
    edited February 2018
    What matters is the number associated with the damage. At he end of an sp3, regardless of how many “hits” were in the sp3 it’s one source. As the damage posted at the end of the animation is only 1 number. An sp3 that has 10 hits doesn’t show 10 numbers at the end of the sp3. SLs sp2 is two hits, however each hit has its own number to it. Hence the 5% armor will only work on the first hit.
  • KhanMedinaKhanMedina Posts: 927 ★★★
    Spark s3 ignores Ice Armor every time. It's ridiculous. 100% of the time, the 30% chance kicks in?
  • The1_NuclearOnionThe1_NuclearOnion Posts: 893 ★★★
    JCPer14 wrote: »
    Noob question, Does Ice Armor ever expire for no reason? I have witnessed it on multiple occasions, in different game modes (i.e. AQ, AW, Monthly Quest, Act 5, mostly arena), against many different champions. I have a 4* 5/50 Iceman sig 63 and have been playing for 3+ years. I am familiar with the game and the bugs.

    Situation is: I'm at high health (60%-95%) Ice Armor is active. I am not receiving hits. I have pushed the opponent to their SP3. I'm in the left side of the screen blocking (with Ice Armor active). Opponent is on the right side of the screen blocking. And....... my Ice Armor just randomly disappears and cool down timer starts. Of course it is then that they fire off their special.

    My question is why would this happen?

    Were you staggered?
  • JCPer14JCPer14 Posts: 79
    No I was not staggered.
  • JCPer14JCPer14 Posts: 79
    Also, staggered removes the buff the moment it activates. Once you have Ice Armor active, Staggering should not be able to remove it. Unless I am wrong.
  • KyrieRedKyrieRed Posts: 202 ★★
    Just fix it like you fixed mordo astral evade. In no time, immediately
  • Wulfgar79Wulfgar79 Posts: 11
    @Kabam Zibiit I just had this happen fighting 6* Karnak in Uncollected difficulty on chapter 2.1 when he used a SP 3. I then tested it on the subsequent champ, Howard the Duck. Pushed him to SP3 and had the same thing happen. Massive damage with no reduction from ice armor.
  • DL864DL864 Posts: 630 ★★★
    Had it happen in aw and modok Challenge got hit with an sp3 in both had ice armor up 60% health r3 5* dead
  • LrrrrLrrrr Posts: 202 ★★
    I know this an old thread @Kabam Miike but this just happened to me against nc’r in aq
  • wilibearwilibear Posts: 30
    This has happened to me a few times
  • Kenny292Kenny292 Posts: 438 ★★
    Had this happen to me the other day against Stark Spidey on the power shield node in AW. I was not stunned and was not below 15%, so pacify and assassin shouldn't have been factors.
  • ShadPrinceShadPrince Posts: 826 ★★★
    AKKKTEK wrote: »
    There is also a bug as it takes incenerate damage from red hulk then what is meaning of incenerate immune?

    If it's the incinerate debuff from the sp3 then it is bugged, yes

    If it's the little red numbers that fly up after every hit, reread the champ description. It's physical damage, not incinerate damage.
  • Tom3579Tom3579 Posts: 49
    This happened to me when versing uncollected crossbones. I was using iceman and went into a sp3 (easier than baiting sp2) and bam, takes me down to no health with ice armour active!
  • ShadPrinceShadPrince Posts: 826 ★★★
    Tom3579 wrote: »
    This happened to me when versing uncollected crossbones. I was using iceman and went into a sp3 (easier than baiting sp2) and bam, takes me down to no health with ice armour active!

    How many furies did he have? Each fury reduces your defensive ability accuracy by 22%, so that one may not have been a bug
  • TKRowlingTKRowling Posts: 17
    I experienced this in AQ map 3 vs. Hyperion. Completely bypassed the ice armor. @Kabam Zibiit
  • ZENZEN Posts: 102
    Iceman Armor is passive. If its UP, Iceman should only lose 5% of max health in one blow. SP3 is consider as one blow. So, that's a bug.
  • 2nd_slingshot2nd_slingshot Posts: 212
    It's only ever happened to me against Black widow, i assumed she reduced ability of the armor.
Sign In or Register to comment.