Alliance Help Event Bugged [Merged Threads]

CyporgCyporg Posts: 231
edited July 2018 in Bugs and Known Issues
I just 'helped' about thirty requests and earned no points toward this event. I had already reached my quota for gaining loyalty, but that shouldn't matter. I don't see that mentioned in the alliance event details. Anyone else experience this?
Post edited by Kabam Lyra on
«134

Comments

  • MhykkeMhykke Posts: 431 ★★★
    I've been both hitting help for alliance mates and requesting help and have gotten zero points in this event.

    Am I missing something?
  • Darkness82Darkness82 Posts: 275
    It’s bugged for me aswell it’s working as intended lol should kabam fix it or leave it fix this bug ASAP thank you?
  • CptMuffinCptMuffin Posts: 85
    Same experience for me.
  • NitoNito Posts: 69
    If you have hit your 1000 loyalty for the day, you can't earn more points until the next day. It's stupid, I know, but that's how it works. Glad they are focusing on this **** instead of fixing bugs that have been in the game for months or years. Good on you Kabam...
  • Tasty_Yum_YumsTasty_Yum_Yums Posts: 437 ★★★
    Same
  • CyporgCyporg Posts: 231
    I read somewhere else that if you hit your loyalty quota, you can't earn pts. How dumb
  • WHBONNEYWHBONNEY Posts: 8
    Same here
  • MhykkeMhykke Posts: 431 ★★★
    Jaded wrote: »
    Only gain points if you also gain loyalty while hitting the help button for others.

    It doesn’t state that but this is how the goal worked previously.

    Yeah, they probably should've added that bit of info...

  • Hyperbolein_1Hyperbolein_1 Posts: 67
    WTF seriously why kabam do this thing?!
  • RockyB239RockyB239 Posts: 696
    If you have received max loyalty for the day you get no points for hitting the help button. There is no mention of this in how to get points.

    useseuy173s7.png
  • ASV27ASV27 Posts: 91
    Didn't work for me. Pretty surprising.
  • DaFaust1DaFaust1 Posts: 5
    You would think this information would’ve been mentioned as it’s pretty important part of the event!!
  • CoBfan1987CoBfan1987 Posts: 227
    yep same issue with me, already had max loyalty once the event started and pressing help 100 more times gave me no points. smfh
  • Sylvia14mkSylvia14mk Posts: 74
    Same.
  • Spidey0486Spidey0486 Posts: 80
    Frustrating!
  • RemeliRemeli Posts: 608 ★★★
    Yep. Not surprising that something else isnt working...
  • Ultra_GalactusUltra_Galactus Posts: 35
    Hi all, brand new event and I'm helping my alliance but the points are not being registered. Only one member in our alliance is able to contribute. Can you take a look?
  • randamusrandamus Posts: 13
    Either an unforeseen bug or if it's not a bug, then extremely poor timing for this event - I suspect most players max out their loyalty a few minutes after it resets - which is 11 hours from now.
  • RockyB239RockyB239 Posts: 696
    Problem is everyone timers reset at different times. This doesn't seem like it's working properly.
  • WeaponXWeaponX Posts: 107
    Our alliance is experiencing the same issue.
  • DrGameDrGame Posts: 9
    Same here
  • WestCoastPartyWestCoastParty Posts: 22
    It should work regardless of loyalty points. Also should have alliance rank rewards to encourage competing and increasing "help" within alliances imo
  • WeaponXWeaponX Posts: 107
    Our alliance is experiencing the same issue
  • Ultra_GalactusUltra_Galactus Posts: 35
    A friend said maybe those with their daily quota at 100% cant contribute any points past that point but it isn't stated anywhere so good to get clarification
  • Spidey0486Spidey0486 Posts: 80
    It doesn't give you points if you have maxed out already!
  • Drakinn73Drakinn73 Posts: 1
    The event opened after I had maxed out for the day I help my alliance all the time, but this wont count towards the 1 day event because I maxed out the daily loyalty. This needs to be thought through more by you guys.
  • Jjjmb5Jjjmb5 Posts: 119
    So i giving help but its saying that no one in my alliance is recieveing points i exited out and went back in and still the same is this a glitch or is it being common right now
  • YoodenVranks_1YoodenVranks_1 Posts: 39
    Some of my alliance members and myself are unable to qualify for the Alliance Help event even though we are clearing the help requests. I’ve tried rebooting the game a few times, still nothing. Am I missing something? Is anyone else seeing this problem?
Sign In or Register to comment.