Units do not add when collecting the rewards.

Hi Team, please check. The rewards in units from the new "summenor journey" does not add when collected. Please check and get back to me.

Comments

  • Especially from the new rewards added. I think I have lost over 100 units. I ignored earlier thinking they will be added a little late, like the other days. But now they are not added... Please check and get back to me.
  • TerraTerra Posts: 2,056 ★★★★
    edited April 2019
    You need to refresh the page for them to appear. If you say get them in EQ, go to home page and they added. If unit purchase it should happen directly. If not, restart game. If none works, it's a bug. Then you should send a ticket to support.
  • I tried every thing. From almost the start of the new update, I haven't been getting the rewards from the tasks.
  • Terra, for some reason it worked now. But generally it does not in the recent past. This is only on the new tasks. Thanks again for your help
Sign In or Register to comment.