Cavalier EQ Skill Path Bugged

ictict Posts: 37
edited March 2021 in Bugs and Known Issues
The Cavalier Skill EQ path is Bugged! It no longer gives you Fury when the Opponent Fails to Evade! Now it is a very long and tedious fight especially with the Evade node! Please fix this ASAP! I still have to 100% Cavalier Difficulty

Note : I use a very recent Android Device so it's not a Device problem

Comments

  • magnus_xixmagnus_xix Posts: 1,653 ★★★★★
    Need more context
  • XedXed Posts: 11
    edited March 2021
    I've uploaded a gameplay for this bug:
    Pardon the gameplay.
    But basically when evade fails Skill champions are supposed to get a fury. This process fails right now.
  • ArifuteraArifutera Posts: 151 ★★
    Yes
    Not working for me as well
  • Man_BatMan_Bat Posts: 327 ★★
    Just tested this as well and it doesn't work for me either. I tried Night Thrasher, Killmonger, Falcon, Nick Fury, and Masacre and none were able to get the fury bonuses.
  • Hey there, passing along the information and video for the team to take a look at.
  • Buck9studioBuck9studio Posts: 134
    I noticed same thing used Nick fury and BWDO and not gaining fury... Makes for longer fights. See pic below no furies whole fight even once evade fails.

  • DJMNHDJMNH Posts: 572 ★★★
    Agree was exploring the same quest.. when I found these two bugs.. one persistent charge issue (nick fury) starts off the fight in phase 2. Issue 2 champs don't gain fury after failed evade
  • DJMNHDJMNH Posts: 572 ★★★

    Hey there, passing along the information and video for the team to take a look at.

    By the time, issue gets fixed last month quest will be over and we won't be able to explore and collect rewards.. @Kabam Zibiit pls get these issues solved by game team asap. Just 15 hours left...
  • Frank_stein066Frank_stein066 Posts: 8


    Grima_094
    Mcoc ver 30.1.0
    Iphone7+ ver 14.3
  • JustinU21JustinU21 Posts: 75 ★★
    Anyone know if this is fixed yet? Quest about to close & this makes clearing the last lanes a major major pain
  • Ace13aAce13a Posts: 3
    Still not working. Guess I’lljust power through.
Sign In or Register to comment.