**Mastery Loadouts**
Due to issues related to the release of Mastery Loadouts, the "free swap" period will be extended.
The new end date will be May 1st.

Sprint / T-Mobile Issues

Knowing from experience and looking at all the other bug reports, I think it's safe to say that one of the major issues right now might not even be Kabam's fault. Sprint and T-Mobile merged recently. I know I still have problems making phone calls using Cellular. The LTE Data connection is just ****. Whatever they did to Merge the towers still isn't working. Now this doesn't affect many other apps that aren't accessing the internet as much (amusingly I can still hotspot with 40mbs), but I'm sure CoC and many other apps play like **** now.

If you are experiencing this issue, I recommend not only letting Kabam know, but also T-Mobile.


  • HoliolioHoliolio Posts: 24
    I have been having problems as well. I am on Google Fi which uses T-Mobile/Sprint towers. Works well sometimes and other times super long load times and kicking me out of war fights before they start. Did your fix work?
    Kabam Boo said:

    Hi folks! We're sorry that you're experiencing these issues on this particular provider. We have logged your reports accordingly and our team will investigate the issue on our end as well. Thanks again for your patience and cooperation in this matter. Cheers.

    Any updates on this issue. I just had a software update from T-mobile and had no problems logging in for like an hour. After it went back to the same issue can't logging to game through T-mobile network has to be wifi. Any updates will be much appreciated @Kabam Zibiit
  • Kabam BooKabam Boo Posts: 840 ★★★★★
    Hi folks!

    We apologise for the delay. Our team is still exploring possible roots to this issue. As this is currently affecting a select group of our players, the issue is not presenting itself as obviously as we'd like. Once again, we apologise for the delay but please know that our engineers are on it!

    Thanks again for your continued patience.
  • OllyoxenfreeOllyoxenfree Posts: 248
    It’s not just sprint/T-Mobile. I use Rogers and I can’t play the game when I switch from wifi to data. Data works still works for playing Transformers: Forged to Fight, just not Mcoc.
  • MalchaeisMalchaeis Posts: 174 ★★
    In my opinion, it feels like if the game loses connection it doesn't try to reconnect. It may show its trying but I've waited 15 minutes on the loading screen without it timing out and saying its lost connection. I have to briefly put my phone in airplane mode to force it to show that screen. Turn off airplane mode and reconnect. I have sprint/ t-mobile on a Samsung galaxy note 20 5g ultra.
  • Kabam BooKabam Boo Posts: 840 ★★★★★
    Your specific incidents on Wi-Fi vs cellular data is very helpful to us! The more specific you can get about when you notice any network issues will certainly aid in this investigation. Please continue to provide information as you have above! Thank you so much!
  • TheYakAttackTheYakAttack Posts: 15
    Any updates on this? I can barely play the game if I'm not on wifi.

    I took a year off from the game due to bugs and unbalanced play. I returned and this issue comes up a month later. The game can be entertaining, but it's not worth 10 minutes of my time to just try and login. Then pray you don't have issues after killing something in AQ/AW to have your health unfairly taken away for the issue.

    With a new season of AQ coming I might as well quit my alliance and try playing solo till it's fixed or delete the game again. It's not worth punishing a group for a handful of us who can only play on wifi.
  • Palh1caPalh1ca Posts: 1
    Really need to fix this connection issue. This is my mobile data speed test. Still takes over a 2 minutes to lig in then when I go to AW I timeout causing a death and me losing 1/2 health. I am a sprint customer. I the game works good when I am on wifi just not on mobile. I even tried to mobile hotspot to my old phone and it has the same issue. Not having any issues with other apps/games
  • AdaletorememberAdaletoremember Posts: 3
    edited December 2020
    Im also having the exact same issues on EE in the UK. I have an iphone 12 pro max and tried a reinstall, diabled 5g etc but still the same :/
  • jake2333jake2333 Posts: 2
    I use my Tmobile carrier to hotspot for other devices. My problem has been since the November update. I have other games that run fine but MCOC is unplayable unless I'm @ home connected to wifi. Network speed of my hotspot is 65mbps.
  • 11993451199345 Posts: 365 ★★★
    Members of my alliance are on other carriers (US and Canada) and they suffer from the same issues to varying degrees...
  • I have been dealing with this issue since the November update. I am tmobile, my connection is usually 4glte with 4 or 5 bars. I can barely log in, let alone do anyting in game. I have timed out of aq and aw fights, lost waste been unable to log in almost all day. To log in some times it takes up to 10 minutes or longer.
    I have deleted mcoc app installed, xleared cache, uodated game, updated phone. Nothing has fixed it.
    I know people who play and have the same issue. But they are on different networks and different phones.
    I can stream hd videos on netfilx, hulu, disney plus, YouTube , i even play 3 other mobile games with no issues.
    As i have played this game for almost 5 years i have not seen an issue this bad in a very long time.
  • We need help. My alliance is about to kick me because I can't play while on mobile data.
  • PizzabeatPizzabeat Posts: 239 ★★
    Still can’t log on to mcoc via cellular T-Mobile 5g data plan on an iPhone 12 pro Max
  • 11993451199345 Posts: 365 ★★★
    Pizzabeat said:

    Still can’t log on to mcoc via cellular T-Mobile 5g data plan on an iPhone 12 pro Max

    Try toggling airplane mode on/off when you get the server connection error icon...more often than not it helps to get the game moving again.

    Connecting issues seem to be more of a communication link issue between the game and the server, as opposed to a carrier or device issue.

    Hope this helps!!
Sign In or Register to comment.