To prevent exploitation, we will prevent new Accounts from being able to Gift enlistment crystals. We will also be taking action on those who are using 3rd Party Sellers, Bots and other farms to gift themselves mass amounts of Enlistment Crystals. Lastly, we will be adding an expiration timer to Enlistment Crystals. All unopened Enlistment Crystals will expire on Oct 18 @ 17:00 UTC. For more information, please see this post: https://forums.playcontestofchampions.com/en/discussion/346104/updates-to-enlistment-gifting-event
We have adjusted the node placement of the new AW maps to better allow path traversal. As a result, defender placements have been reset. Please, take a moment to re-place your defender setup. We will be pushing out a message in-game shortly.

Relics: Bug Report Thread



  • GregglesWinsGregglesWins Posts: 17
    edited March 16
    Relic page is broken again...says need to complete tutorial and have to close game if enter page. Great job everyone.
  • OpxOpx Posts: 117
    Relic still dont work. When open pages whit relic, game frezze. I need restart game.
  • GrabGrab Posts: 71
    same. entering relics screen forces original relics tutorial and upon finishing taps, can’t do anything. can’t go back to menu, or do anything within relics, can’t even open store to buy 75 odins packs i was about to buy…oh well. have to restart game.
  • SaltE_Wenis69SaltE_Wenis69 Posts: 1,758 ★★★★
    whats the point of making this thread kabam if you never check it
  • GoosherGoosher Posts: 1
    Never got my cav event quest rewards. Shows completion but that's it.
  • Lee99Lee99 Posts: 91

  • Troy_Elric123Troy_Elric123 Posts: 542 ★★★

    Hey all,

    Once you go to the Relics for the first time, you will have to do the Tutorial and Bind a relic, but remember that it DOES NOT COST anything to unbind a Relic for your first few times. You do not have to pay for any until 7 Unbinds.

    More information in the "Relic and Battlecast Details" section of this post: https://playcontestofchampions.com/news/what-are-relics/

    Is that 7 unbinds of same/one specific relic or as a whole?
  • Was fighting in BG and the screen before the fight was blank. Fight started and I beat terrax in under a minute. After the fight it said I died in 7 seconds….. lost the whole thing since I threw the first match….been having a lot of issues lately please help
  • BigPoppaCBONEBigPoppaCBONE Posts: 2,051 ★★★★★
    Why are all these Battlegrounds bugs in here, not being deleted? Are they still looking at bugs for relics?
  • Phantom_blaq8Phantom_blaq8 Posts: 1
    Trying to attach a Relic to Hercules and unbind relic from Rintrah. The game thinks they are in a quest, which they're not, It was like this in the March build and still the same in the April update.

  • Pin_the_AvengerPGT17Pin_the_AvengerPGT17 Posts: 316 ★★
    I’m currently having issues with certain relics not showing. Thankfully they’re all bound to champs (as far as I know of).

  • Pin_the_AvengerPGT17Pin_the_AvengerPGT17 Posts: 316 ★★
    Apparently they showed themselves after reloading the game.

  • lozzadudelozzadude Posts: 156
    edited April 16
    I can’t bind relics to my 6* Domino & 5* Red Hulk & Masacre. They’re not in any quests, arenas, etc. It’s been like this since relics were introduced. I raised a ticket & nothing was resolved. I use Domino a lot so this is annoying.

    If a champ is in a quest or arena this info is displayed at the top. e.g.

    The champs I can’t bind to, that aren’t in a quest, don’t have this. They’re probably being registered as being in some old content still. Surely it can’t be that hard to fix this bug.

  • PowPow48PowPow48 Posts: 8
    I am not able to bind my relics to my champs. I select and bind to a champ and animation pops up and say it's bound but when I try to exit. It says you are leaving without binding after I did bind.
  • MBoguszMBogusz Posts: 93
    PowPow48 said:

    I am not able to bind my relics to my champs. I select and bind to a champ and animation pops up and say it's bound but when I try to exit. It says you are leaving without binding after I did bind.

    Same issue

  • Denslo500Denslo500 Posts: 887 ★★★
    @Kabam Miike can someone please tell us how to fix the “champ in a quest can’t unbind” when the champ is not in a quest???

    I have tried: turning off game and resetting phone. No change.

    Wolverine relic
    Magneto white champ is my worst offender combo
  • PsycheMikePsycheMike Posts: 32
    I am also unable to bind any of my unbound relics to champions. The animation plays to say relic bound but it doesn’t actually bind to the champion.
    Unable to unbind 3*Thor relic/ bind 5* thor relic to herc. Said Herc is in a quest when he isn’t. Any idea on how long this will be broken for?
    Jeal79 said:

    Unable to bind relic to a champ used in war attack. War is still in progress but the boss is beaten and my champs have been released yet still unable to bind.

    I have same problem with that.. I can't bind relic to nimrod..
  • AragornautAragornaut Posts: 26
    I can’t bind relics. After selecting “bind relic”, there’s just the (grandmaster?) symbol spinning along with the wifi symbol which is now a common occurrence:

    If I exit I get the message that I’m leaving without binding. When I get back, the relic is indeed not unbound.
  • Sakic19Sakic19 Posts: 98
    I would just like to rank up or look at my relics without having to do the tutorial AGAIN! I have done it once already so why am I having to do it again? I can only assume it is broke, like most things in the game, accept buying things I am sure!
  • @Kabam Miike I don't know how else to report this as it's impossible to find out, I have just become paragon and have completed all level 5 sections on this month's side quest but I have not been given any rewards for it? Is this a know issue?
  • McsizzleMcsizzle Posts: 1
    My relic problem is that it is showing a relic (3* venom) is bound to a 6* hulkling. Only problem is, I don't own a 6* hulkling. It won't let me unbind the relic (i go through unbind process but it just still stays bound to the nonexistent 6* hulkling), so I cannot bind and use it with any champ I actually own.
  • 5ra5ra Posts: 30
    What Champion were you using?
    Absorbing Man
    What Relic were you using?
    Iron Fist
    What Champion were you fighting against?
    Describe the Issue
    Relic is hitting into block after activating
    What actions did you use leading into this? (ie. I launched the Striker after a MLLLLM Combo)
    Used striker after MLLLM combo
    Any other information that you think is important
    Happened in bgs fight
  • Lighten_DarkLighten_Dark Posts: 40
    I currently can't bind, unbind, or swap relics. None of my champs are questing. Is anyone else having this problem? I have rebooted several times. No resolution.

  • Nuke_EmNuke_Em Posts: 2

    I currently can't bind, unbind, or swap relics. None of my champs are questing. Is anyone else having this problem? I have rebooted several times. No resolution.

    Yes, same! Just popped 5-star Valkyrie relic and I have no way to unbind the Black Panther relic on Valkyrie to add the new relic! 😡
  • 5wapn5wapn Posts: 4
    edited June 22
    Can’t bind my 3 star Gambit relic to 6 star Kitty. The stupid node Spiritualizm-1 makes Event Quest 2.2 lane pain-in-the-ass without the striker.
  • PowPow48PowPow48 Posts: 8
    Why any and every time I want to do any changes to Relics they are bugged? You want people to start using them more but it's constantly having issues. I don't look forward to playing 8.3 and being forced to use them and having problems making any changes every lane.
  • emsehvenemsehven Posts: 32
    I remember that the crit rating for the Gambit relic (even for a 4 star) was around 2k plus. However, when I checked now, it only goes up to 800. I checked other youtube videos and the 4 star should have 2k plus crit rating. Not sure if I am missing anything, or there was a change during the update
  • Casal_TCasal_T Posts: 63
    RELICS WILL NOT BIND. I have deleted and reinstalled the game. Regardless of whether I pick the champion first or the relic first, when I tap bind, nothing happens. I have tried 4, 5, 6, & 7 star champs with 3, 4, & 5 star relics and none work. I have the most up-to-date game version and android OS version. Also, I opened a helpdesk ticket and did not receive an acceptable answer.
Sign In or Register to comment.