**Mastery Loadouts**
Due to issues related to the release of Mastery Loadouts, the "free swap" period will be extended.
The new end date will be May 1st.

Where is the summoner appreciation package [Merged Threads]



  • Didn't work for me either
  • FineDogFineDog Posts: 403 ★★★
    Yup, same here. This is pretty dumb, you guys.
  • AndyspirosAndyspiros Posts: 17
    Doesn’t work
  • JuancasilJuancasil Posts: 23
    I have completely restarted the game and still no rewards choice
  • BlueCrabEaterBlueCrabEater Posts: 11
    Restarted and there was still nothing.
  • Didn’t work for me either. Still no sa gift options. Tried restarting twice, then logged out and restarted app, logged back in. Still nothing.
  • tonyj007tonyj007 Posts: 276
    closed game, uninstalled reinstalled, still nothing in mail. A new bug i suppose . I did get the boost and crystal. be thankful that something works
  • This is hilariously frustrating. Get your **** together KABAM. Seriously this is the first game I have played that encounters a bug on daily basis.
  • CallmelaFleurCallmelaFleur Posts: 231
    Sorry @Kabam Miike The little gift box wasn't even in my in game mail this morning. Just the crystal. I opened it on a live stream.
  • Bigboy1081Bigboy1081 Posts: 32
    Yep it didnt work for me either

  • Smitty138Smitty138 Posts: 104
    I got nothing still.
  • PlagueisBanePlagueisBane Posts: 232
    same same...
  • I feel so appreciated
  • Restarted twice and nothing. Logged out, restarted. Logged back in and still nothing.
  • G0311G0311 Posts: 913 ★★★
    Do they mean reinstall the app
  • SMiller80SMiller80 Posts: 230 ★★
    Yeah, this definitely didn't work.

    Did it work for anyone?
  • Restarting definitely doesn’t work @Kabam Miike @Kabam Lyra
  • FrostyFrosty Posts: 485 ★★★
    I restarted multiple times. Still no appreciation package.

    Severely underappreciated
  • CallmelaFleurCallmelaFleur Posts: 231
    Guys. I'm frustrated too but having to sift through snarky comments isn't going to help.
  • BrainimpacterBrainimpacter Posts: 578 ★★★
    so @Kabam Miike I did what you said and restarted the app and still nothing no popup
  • Ghostspider231Ghostspider231 Posts: 298 ★★★
    Guys. I'm frustrated too but having to sift through snarky comments isn't going to help.

    Then forums are no place for you lol

  • BlackOracleBlackOracle Posts: 254 ★★★
    @Kabam Miike - Yeah, it didn't work.
  • RiegelRiegel Posts: 1,088 ★★★★
    So you said it's fixed, but it's not...
  • Vossler77Vossler77 Posts: 683 ★★
    Nothing here. Git the crystal this afternoon. Nothing since. Restarted multiple time. Updated to 19.1.1 nothing
  • NheyyzNheyyz Posts: 7
    Yep restarted multiple times still nothing.
  • Sylvia14mkSylvia14mk Posts: 73
    Restarted, still nothing.
  • Jjjmb5Jjjmb5 Posts: 119
    Me too
  • MfallsMfalls Posts: 94
    Hey All,

    We've just started sending out the missing Gifts to players that couldn't trigger it the first time. If you have not yet received it, please close the app completely, and reopen it.

    Thank you for your patience as we worked to resolve this issue.

    Well it’s been about an hour now and sounds like “the fix” didn’t work. Are these rewards supposed to appear in mail, just appear when the app opens or elsewhere in the game? It’s going on 6pm on a Friday out there I hope those able to fix it before they leave for a couple of days...
Sign In or Register to comment.